
1) Download “Workshop table 1.csv” & “Workshop table 2.csv” to a location you can find easily like your
desktop.

2) Open the workshop files with the “Open>This PC>Location”, where you downloaded the files.

3) Select the file named “Workshop Table 1.csv” then click the “Open” button.

Excel for Research Workshop - Windows

Open Workshop Files



4) When the Text Import Wizard Step 1 dialog box opens click the “Next” button (Make no changes).

5) When the Text Import Wizard Step 2 dialog box opens un-check the “Tab” checkbox and select the
“Comma” checkbox then click on the “Next” button.



6) When the Text Import Wizard Step 3 dialog box opens just click on the “Finish” button.

7) You should see a warning along the bottom to the tool bar indicating you should save your workbook as
Excel format.

8) Click the “Save As..” Button in the warning banner.

9) When the Save As dialog window opens make sure you change the format to “Excel Workbook (.xlsx)”
format (note failure to do this will prevent several features form working as described in this tutorial).



10) Select a location to save the file where you can find it again file like the desktop.

11) The next step is to import the second file as a new sheet in the workbook. Select the “Data Tab” then
select “Get Data > From File > From Text/CSV”.

12) When the Import Data dialog opens select the “Workshop Table 2” file then press the “Import” button.



13) When the import dialog box opens, make sure “Comma” is selected as the Delimiter then click the “Load”
button at the bottom of the dialog window

14) The file will be loaded into a new worksheet
and converted to a table.

15) Change the name of the worksheet
from Sheet2 to Workshop Table 2. To do this,
“Right Click,” the sheet tab, and
select “Rename.”



Data Cleaning

1) Switch back to the first worksheet named
“Workshop Table 1.”

2) Select cell “A3.”

3) Click on the “Home” Tab then in the Editing
section of the toolbar click and select “Find and
Select> Go To..”

4) When the Go To dialog box opens, click the
“Special…” button.

5) On the Go To Special dialog box, select
“Blanks,” then click “OK.”

6) Make sure cell “A3” is still selected (don’t click
anything. Leave the focus on the cell under
Alabama).



7) Type in “=“ then click on the cell that contains
“Alabama.”

8) Next, while holding down the "Ctrl key” press
"Enter". All the empty cells should now have
populated with state names.

9) Next, convert the newly pasted formulas to
values in this case state names.

10) To convert the values, select the whole column
“A” that contains the state names.

11) Copy the contents of the column by either
using the "Ctrl" and "C" keys or use the copy
command in the "clipboard section" of the
"Home" Tab.

12) Select "Paste > Paste Special…" in the
"clipboard section" of the "Home" Tab.

13) When the Paste Special dialog
box opens select “Values” form the
Paste section and “None” from the
Operation section, then click “OK”

14) Press the “Esc” key to de-
select the first column. If you
select one of the cells, you just
pasted, it should now contain a
state name vs. a formula.



Split a field

1) In the Workshop Table 1 worksheet column "B"
has a problem. There should be two columns of
data where there is only one. To correct this error,
the single-column will need to be split into two.

2) First, select the column “C.”

3) Next form the "Home" Tab in the "cells
section," select "Insert>Insert Sheet Columns" to
insert a new empty column to the right of column
"B."

4) Column “C” should now be empty.

5) Select column “B”

6) Click on the "Data" tab and then click on the
"Text to Columns" button in the "Data Tools
section".



7) When the Convert Text to Columns Wizard
Step 1 dialog box opens, select “Delimited” then
press the “Next” button.

8) When the Convert Text to Columns Wizard
Step 2 dialog box opens, select “Space.” As you
can see, the data is being split correctly, but the
header is not because there is more than one
space in the header title. Click on the “Back”
button.

9) When the Convert Text to Columns Wizard
Step 1 dialog box opens, select “Fixed” width
and then press the “Next” button. 10) Now the columns and headers look correct

click the “Next” button.

11) Now there should be two columns where
there was once only one.



Make Tables
1) The next step is to turn our data into tables.
Goto the worksheet "Workshop Table 1" and select
the cell "A2”.

2) Click on the “Insert” tab then click on the
“Table” button in the tables section.

3) A dialog box will open and ask what range of
cells should be included in the table. The data
should already be selected. You should see a
dotted line around your data if not drag your
mouse cursor over your data until it is selected.
Make sure “My table has headers” is selected then
click “OK.”

4) The cells containing your data should now be
converted to a table.

5) Next, we want to remove any duplicate records
in the table. Select any cell in the table.

6) Select the "Data" tab then click the "Remove
Duplicates" button in the "Data Tools section".



7) A dialog will open asking what fields to use in
the search. Leave them all selected and press the
“OK” button.

8) A dialog should open, displaying the results.

Table Join

1) In this section, we will “Join” two tables using
“VLOOKUP.”

2) VLOOKUP relies on being able to "connect" the
two tables by a related field. This field does not
exist in either table, so we will need to make it by
using a calculation that combines two other cells
to create a unique value for each record (row). Go
to the Workshop "Table 1 worksheet" and select
Cell "A2".

3) Next, with cell "A2" selected "Right-click," a
menu will open. Select "Insert>Table Columns to
the Left."



4) A new empty column should appear on the left. 5) Rename the Column to ID

6) To create a unique value that we can use to
connect the two tables, we will combine the "State
name" and "Year" cells into a new cell in the row we
just created.

7) Select cell "A2" and type "= "then click on cell
"B1". Next type "&" then click on cell "C1". Last,
click on the "Check" icon next to the formula bar or
press the "Return" key to complete the calculation.

8) The table should auto-fill the new formula in
column “A” and display the result.



9) Next, go to the "Workshop Table 2" worksheet
and repeat the same process. When completed,
"Workshop Table 2" should look like this.

10) Click on the "Table Design" Tab and make a
note of the "table name" and "Column Numbers"
you want to display in the other table. You will
need this information in step “18.” In this case, the
table name is "Workshop_Table_2__2" (your table
name may differ), and the columns are "4" & "5"
we want to return to the other sheet.

11) Return to “Workshop Table 1.”

12) Select cell "I1" and type "Single-Vehicle,"
then press "Return." A new empty table column
will appear.

13) Repeat the process this time select cell "J1"
and type "Multiple-Vehicle." in the cell. You should
now have two new empty columns on the right
side of your table.

14) Select the first empty cell under the “Single-
Vehicle” header.



15) Click on the "Formulas" tab then select
"Insert Function" from the "Function Library"
Section.

16) The "Insert Function Dialog" will open. From
the "Or select a category" pop-down menu, select
“All.” Then scroll through the list of functions until
you find "VLOOKUP"

17) Next The Function Arguments window will open.

18) You will now need the values you made a note of
in step “10”. For the "Lookup_value," click in Cell
"A2." For the "Table_array" type, the name of the
Table on the "Workshop Table 2" worksheet. For the
"col_index_num," enter the number "4." For the
"Range_lookup," enter "FALSE." Last Click, “OK.”

19) Column “I” should now be filled with related
values form “Workshop Table 2”.



20) Next, we want to repeat the process for
column "J," but instead of re-typing the whole
formula, we can copy-paste the formula from cell
"I2" into the cell "J2" and change the
"Col_index_num" value from "4" to "5".

21) Column “J” should now be filled with related
values form “Workshop Table 2.”

PivotTables

A pivot table is a table that summarizes data in another table and is made by applying an operation such as
sorting, averaging, or summing to data in the first table, typically including grouping of the data. - Wikipedia

1) In “Workshop Table 1” select cell “A2”.

2) Select the "Insert" tab in the toolbar then click
the "PivotTable" button in the "Tables" section.

3) When the Crate PivotTable dialog box opens,
make sure “Select a table or range” is selected, and
“Table3.” is being displayed in the edit box. (This
name might differ on your computer, but will always
be the name of the table you just selected.) Next,
make sure the “Choose where to place the
PivotTable” is set to “New worksheet.” Click the
“OK” button.



4) A new sheet will be created, and the PivotTable Fields dialog will be displayed.

5) Below is a brief description of
what the different parts of the
PivotTable Fields dialog represent.



6) The easiest way to understand PivotTables is to play with the interface. Let's start by dragging the "State"
field from the "Field Name" section to the "Rows" section. As you can see the state names fill out in the first
column. You might also notice in "Worksheet table 1" the state names repeated once per year to create 613
rows. The PivotTable has summarized this into 51 rows, one entry for each state, plus one territory.

7) Next, drag the "Year" field from the "Field Name" section
to the "Columns" section. Now, the years are displayed across
the top of our table.



8) The next question to answer is what data do we want to see displayed for the various
states and years. Drag “Passenger car occupants” from the “Field Name” section to the
“Values” section. Passenger car occupants will now be displayed by year and state.

9) Let's add more data. In the "Field Name" section, check the "Pickup and SUV
occupants" field. The data now displays alongside the "Passenger car occupants"
data. Although we can see all of our data, it's hard to read in this form.



10) Now let's try dragging "Values" from the "Values" section to the "Rows" section. Now,
we see the data is more readable. We have changed the display to "Pivot" our values from
columns to rows, making it more readable.

11) Select the remaining fields in the "Field Names" section to see the rest of the data
displayed in the table. By playing with the order and position of the various fields, you will
be able to visualize your data in different ways.



12) To remove the totals and subtotals form a PivotTable. Select a cell in the PivotTable click on the
"Design" tab (this tab and the PivotTable Analyze tab are only visible when a PivotTable is selected).

13) Click on the “Grand Totals” button and select “Off for
Rows & Columns.” The table will now display without totals
and sub-totals.



15) Select the Pivot Table you want to filter on then click the “PivotTable Analyze” tab. Next, click
the “Insert Slicer” button.

16) The Insert Slicers dialog box will open, allowing you to
select what fields to filter on. For now, leave “State” selected
and click the “OK” button.

14) Slicers allow you to control how much of your data is displayed in the Pivot Table.

17) A floating window will open, allowing you to filter on various
states by clicking the "State name" in the Slicer window.



18) Clicking on the state names in the Slicer window "filters" your table to only the values you selected in
this case "State names."

Conditional Formatting

1) What if we wanted to see in a graphic illustrating how different states compare in how many people were in
a car when an accident occurred year over year? We could use Conditional Formatting to help us.

2) First, adjust your PivotTable to show “Year” in the Columns, “State” in the Rows, and remove all of the
other categories except “Passenger car occupants” in the Values section by deselecting them in the fields list.



3) Using your mouse, select the range of values you want to
format. Select only the “Passenger car occupants” data and
nothing else. 4) Select the "Home" tab then click on

the "Conditional Formatting" button in the
"Styles Section".

5) Next, a pop-up list will appear, displaying
several options. As you drag over each
option, you will be able to preview how the
formatting will appear. Select the “Color
Scales>Red-Yellow-Green Color Scale.”
option.



6) The cells of our PivotTable should now be colored based on their
values. Red for high values and green for low values.

7) You can combine several "Conditional
Formatting" rules to make more complex
graphics. Let's add an arrow to each cell
to illustrate the numeric trend. Repeat
steps 3, 4, and 5. When the pop-up list of
formatting options appears select "Icon
Sets>5 Arrows (colored)"



8) Our PivotTable now illustrates a heat table and trend arrows.


