
1) Download Workshop table 1.csv & Workshop table 2.csv to a location you can find the files.

2) Open the workshop files with the File>Open… Menu item

3) Select the file named Workshop Table 1.csv then click the “Open” button.

4) When the Text Import Wizard Step 1 dialog box opens click the “Next” button (Make no changes).

Open Workshop Files
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5) When the Text Import Wizard Step 2 dialog box opens un-check the “Tab” checkbox and select the “Comma” checkbox then click on the “Next” button.

6) When the Text Import Wizard Step 3 dialog box opens  just click on the “Finish” button.



7) You should see a warning along the bottom to the tool bar indicating you should save your workbook as Excel format. 

8) Either click the “Save As..” Button in the warning or goto “File>Save As..” menu item and save the file.

9) When the Save As dialog window opens make sure you change the format to Excel Workbook (.xlsx) format (note failure to do this will prevent several features form working 
as described in this tutorial).

10) Select a location to save the file where you can find it again file like the desktop (the name is not important and will likely be Workshop Table 1 by default).



11) The next step is to import the second file onto a new sheet in the workbook. Select the “File>Import” menu item.

12) When the import dialog box opens select “CSV” file from the list.

13) Next you will be asked where is the file you want to import. Navigate to the Worksheet Table 2.csv select the file and click the “OK” button.



14) Next the the Text Import Wizard Step 1 dialog box will open just click on the “Next” button (make no changes)

15) When the Text Import Wizard Step 2 dialog box opens make sure "Comma" is the only checkbox checked then click the "Next" button.

16) The last step is to select “New Sheet” then “OK”. A new worksheet will be created with the data from the  Worksheet Table 2.csv file in it.

1) Switch back to the first worksheet named Workshop Table 1.

2) Select the cell directly under first state Alabama.

Data Cleaning



3) Select the menu item “Edit>Find>Go To..”

4) When the Go To dialog box opens click the “Special…” button.

5) On the Go To Special dialog box select “Blanks” then click “OK”.



6) With the cell still selected (don’t click anything just leave the focus where it is on the cell under Alabama).

7) Type in “=“ then click on the cell that contains “Alabama”.

 

8) Next while holding down the "Control" key press "Enter". All the empty cells should now have populated with state names.

9) Next select the whole column  (A) that contains the state names.



10) Copy the contents of the column by either using the “Command” and “C” keys or the copy command from the “Edit>Copy” menu item.

11) Select “Paste Special…” form the Edit menu.



12) When the Paste Special dialog box opens select “Values” form the Paste section and “None” from the Operation section then click “OK”

13) Press the “Esc” key to de-select the first column.

1) In the Workshop Table 1 worksheet column "B" has a problem. There should be two columns of data where there is only one. To correct this, the single column will need to 
be split into two.

2) First select the column “C”.

3) Next form the Insert menu select “Columns” to insert a new empty column to the right of column “B”

Split a field



4) Column “C” should now be empty.

5) Select column “B”

6) Click on the “Data” tab and then click on the “Text to Columns” button.

7) When the Convert Text to Columns Wizard Step 1 dialog box opens select “Delimited” then press the “Next” button.



8) When the Convert Text to Columns Wizard Step 2 dialog box opens select “Space”. As you can see the data is being split correctly, but the header is not because there are 
more than one space in the heater title. Click on the “Back” button.

9) When the Convert Text to Columns Wizard Step 1 dialog box opens select “Fixed” width this time and then press the “Next” button.



10) Now the columns and headers look correct click the “Next” button.

11) Now there should be two columns where there was once only one.



1) The next step is to turn our data into tables. Goto the worksheet Workshop Table 1 and select the first cell “A1”.

2) Click on the “Insert” tab then click on the “Table” button.

3) A dialog box will open and ask what range you want to be included in the table. The data should already be selected. You should see a dotted line around your data if not 
drag your mouse cursor over your data until it is selected. Make sure “My table has headers” is selected then click “OK”.

Make Tables



4) The data should now be converted to a table.

5) Next we want to remove any duplicate records in the table. Select any cell in the table.

6) Select the “Data” tab then click the “Remove Duplicates” button.



7) A dialog will open asking what fields to use in the search. Leave them all selected and press the “OK” button.

8) A dialog should open displaying the results.

9) Next goto the Workshop Table 2 worksheet.

10) Select cell “A1”.

11) Select the “Insert” tab then press the “Table” button.

12) A dialog box will open asking what range you want to be included in the table. As with the previous table the data should be selected if not select the data. Make sure “My 
table has headers” is selected then click “OK”.



13) This time a dialog will open warning you your selection overlaps with external data ranges. Click the “Yes” button.

14) A new table is created from the existing data.

15) Select any cell in the table and then select the “Data” tab then click on the “Remove Duplicates” button.

16) A dialog will open asking what fields to use in the search Leave them all selected and press the “OK” button.



17) A dialog will open displaying the results.

1) In this section we will “Join” two tables using “VLOOKUP”

2) VLOOKUP relies on being able to “connect” the two tables by a related field. This field does not exist in either table so we will need to make it using other fields. Go to the 
Workshop Table 1 worksheet and select the first column in the table. 

3) Next “Right click” and a menu will open. Select “Insert>Table Columns to the left”.

Table Join



4) A new empty column should appear on the left.

5) To crate a unique value that we can use to connect the two tables we will combine the State name and Year. 

6) Select cell “A1” and type “=“ then click on cell “B1”. Next type “&” then click on cell “C1”. Last  click on the “Green Check” icon next to the formula bar.

7) The table should auto fill the new formula in column “A” and display the result.



8) Next goto the Workshop Table 2 worksheet.

9) Select column “A” in the table. 

10) Next Right click and a menu will open. Select “Insert>Table Columns to the left”.

11) A new empty column should appear on the left.



12) Select cell “A1” and type “=“ then click on cell “B”. Next type “&” then click on cell “C1”. Last click on the “Green Check” icon next to the formula bar.

13) The table should auto fill the new formula in column “A” and display the result.

14) Make a note of the “table name” and “Column Numbers” you want to display in the other table. In this case the table is “Table2” and the columns are “4” & “5”.

15) Return to Workshop Table 1.

16) At the far right column of the table type in the header cell “Single-Vehicle” then press “Return”. A new column will appear.



17) Repeat the process again this time typing “Multiple-Vehicle”  You should now have two new empty columns on the right side of your table.

18) Select the first empty cell under the “Single-Vehicle” header.

19) Type the following formula “=VLOOKUP”. As you type a popup should appear you can either type the function or select it form the list.

20) Another popup will appear showing you what arguments are required for the formula.

21) Next click cell “A2”. This is the cell with our unique lookup value.

22) Next type “,” then start typing “Table 2” (the name of the table in our other worksheet). A popup will appear with the tables in our worksheet you can select from the list or  
simply type it in.



23) Next type “,” then “4” (this is the column we want to return form the other worksheet).

24) Finally type another “,” and the word “FALSE” (do not pick FALSE from the popup list). Click the “Green Check” to accept the formula.

25) Column “D” should now be filled with related values form Workshop Table 2.

26) Next we want to repeat the process for column “J” but instead of re-typing the whole formula we can simply copy paste the formula in to the cell and change the column 
to return value. Select cell “I2”

27) Select the formula in the formula bar.



28) Copy the formula to the clipboard.

29) Press the “Esc” key to de-select the formula. Select cell “J2”.

30) Paste the formula into the cell.

31) Next edit the formula and change the “4” to a “5”. Press the “Green Check” box. The last column should now auto fill out with the values form Table2.

A pivot table is a table that summarizes data in another table, and is made by applying an operation such as sorting, averaging, or summing to data in the first table, typically 
including grouping of the data. - Wikipedia

1) In Workshop Table 1 select cell “A2”.

2) Select the “Insert” tab in the toolbar then click the “PivotTable” button.

PivotTable



3) When the Crate PivotTable dialog box opens make sure “Select a table or range” is selected and “Table1” is being displayed. In addition make sure the “Choose where to 
place the PivotTable” is set to “New worksheet”. Next click the “OK” button.

4) A new sheet will be crated and the PivotTable Fields dialog will be displayed.



5) Below is a brief description of what the different pars of the PivotTable Fields dialog represent.



6) The easiest way to understand PivotTables is to play with the interface. Let’s start by dragging the “State” field from the “Field Name” section to the “Rows” section. As 
you can see the state names fill out in the first column. You might also notice in worksheet table 1 the state names repeated one per year to create 613 rows. The PivotTable 
has summarized this into 51 rows.

7) Next drag the "Year" field from the "Field Name" section to the "Columns" section. Now, we have years across the top of our table.



8) The next question to answer is what data to we want to see displayed for the various states and years. Drag “Passenger car occupants” from the “Field Name” section to 
the “Values” section. Passenger car occupants will now be displayed by year and state.



9) Let’s add more data. In the “Field Name” section check the “Pickup and SUV occupants” field. The data now displays along side the Passenger car occupants data. We 
can see although all of our data is being displayed it’s hard to read in this form.



10) Now we will try dragging "Values" from the "Values" section to the "Rows" section. Now, we see the data is more readable. What we have done is to change the display 
"Pivot" our values from columns to rows making it more readable.



11) Select the remaining fields in the "Field Names" section to see the rest of the data displayed. By playing with the order and position of the various fields, you will be able to 
visualize your data in different ways.



12) To remove the totals and subtotals form a PivotTable. Select a cell in the PivotTable. Next click on the "Design" tab (this tab and the PivotTable Analyze tab are only visible 
when a PivotTable is selected).

13) Click on the “Grand Totals” button and select “Off for Rows & Columns”. The table will now display without totals and sub-totals.



14) Using Slicers - Filter buttons.

15) Select the column you want to filter on then click the “PivotTable Analyze” tab. Next click the “Insert Slicer” button.

16) The Insert Slicers dialog box will open allowing you to select additional fields to filter on. For now just leave “State” selected and click the “OK” button.

17) A floating window will now appear allowing you to filter on various states by clicking the state name in the Slicer window.



18) Clicking on the state names in the Slicer window “filters” your table to only the values you selected. 

1) What if we wanted to see in a graphic illustrating  how different states compare in the category of numbers of passenger car occupants? We could use Conditional 
Formatting to help us.

2) first adjust you PivotTable to show “Year” in the Columns, “State” in the Rows, and “Passenger car occupants” in the Values section.

Conditional formating



3) Using your mouse select the range of values you want to format. Select only the “Passenger car occupants” data and nothing else. 



4) Select the “Home” tab then click on the “Conditional Formatting” button.

5) Next a pop-up list will appear displaying several options. Select “Color Scales>Red-Yellow-Green Color Scale”.

6) The cells of our PivotTable should now be colored based on their values. Red for high values and green for low values.



7) You can combine several Conditional Formatting rules to make more complex graphics. Lets add an arrow to each cell to illustrate the numeric trend. Repeat steps 3 & 4. 
When the pop-up list of formatting options appears select “Icon Sets>5 Arrows (colored)”



8) Our pivotTable now illustrates a heat table and trend arrows.



1) Open the worksheet or workbook you want to import your data into. Then select the “Data” tab.

2) Next click on the “New Database Query” button. When the pop-up menu appears select “From Database”

External Data Sources



3) The iODBC Data Source Chooser dialog box will appear.

4) Select the database connection you would like to use.

5) Next the Microsoft Query dialog will open asking you to select the table you want to import. As you select tables an SQL statement will be created to import the table you 
requested.



6) Once you have selected the table click the “Run” button and the SQL Query will run showing you what will be imported. If the data looks correct click the “Return  Data” 
button.

7) Next the Import Data dialog will open. Click on either “Existing Sheet” or “New Sheet” depending on where you want your data to be returned. 



8) The table should now successfully imported into your spread sheet.


